Et si on générait du texte automatiquement avec Excel ?

Excel est un super outil pour le SEO, et pas uniquement pour gérer les tableaux de bord ou pour traiter des listes. On peut aussi s’en servir pour un tas d’autre choses. Voici un petit exemple qui illustrera comment Excel permet de générer du texte dynamique.

Prenons un petit exemple, j’ai envie de créer un site sur le tennis. Sur ce site j’ai envie d’y placer des pages sur chaque joueur de tennis dans lesquelles je souhaite y placer un peu de texte afin de plaire à Google.

Voici le genre de texte que je souhaite générer :

Nadal aime jouer sur le court central de Roland Garros qu’il a remporté 8 fois
Federer adore le tournoi de Wimbledon qu’il a remporté 7 fois
Djokovic aime jouer sur le court central de l’Open d’Australie qu’il a remporté 4 fois

Etape 1

Je vais commencer par lister les joueurs ainsi que leur tournoi préféré et leur nombre de victoires :

Pour chaque élément je vais lui assigner un identifiant numérique (ça me simplifiera la vie tout à l’heure)

 Etape 2

Dans une seconde feuille, je vais gérer les règles de spin (oui je sais le spin c’est mal !!!).

La première colonne contient l’identifiant.

La seconde contient mes deux variantes pour le 1er spin

La troisième contient mes deux variantes pour le 2ème spin

Etape 3

Je peux maintenant définir quel valeur je vais appliquer pour chaque spin.

Je crée une colonne dans mon premier tableau dans laquelle je vais un mémoriser le modulo 2 de l’identifiant de mon joueur

Ca va retourner la valeur 1 pour les identifiants impaires et 0 pour les identifiants paires.

Formule : =MOD(D2;2)

A l’aide de la fonction « rechercheV », je vais donc pouvoir aller cherche la règle de spin qui m’intéresse.

Formule : =RECHERCHEV(E2;Feuil2!A:B;2;FAUX)

Etape 4

Je n’ai plus qu’à concaténer mes éléments pour générer un texte automatique pour chaque joueur

Formule : =A2& » « &F2& » « &B2& » qu’il a « &G2& » « &C2& » fois »

Voici le résultat :

Voir le fichier : spin tennis

 

 

 

3 réflexions au sujet de « Et si on générait du texte automatiquement avec Excel ? »

  1. Bonjour,

    Cette utilisation du logiciel Excel est intéressante, mais je trouve plus simple d’utiliser directement un logiciel de spin, d’autant plus qu’il en existe des gratuits qui restent bons comme Effispin, qui est en français, pour ne rien gâcher 😉

    Cordialement,

    Bruno

    1. Hello,

      Je ne connaissais pas Effispin. Je viens d’aller jeter un oeil. Ca semble être un logiciel fort sympatique. Merci pour la découverte ;-))

      L’idée de départ de mon article était de montrer que les outils du quotidien (type Excel) pouvaient nous permettre de faire des choses sympa à partir du moment ou on a un peu d’imagination.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *